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Introduction 
Podbat is a bioinformatics tool to visualize, analyze and store genomic positioning data. 
Data can be experimentally derived from ChIP-chip, ChIP-seq or expression microarrays. 

User interface 

Getting started 
First, download and install Podbat. Double-click on the podbat.jar file Podbat icon (for 
the Mac bundle) to start Podbat. Alternatively, go to the command line, move to the 
directory where you saved Podbat and type java -jar podbat.jar -Xmx1G (The -
Xmx1G part will set the memory allocated to the program to 1GByte). The first time you 
open Podbat, it will ask you to select which organism you wish work on and the version 
of its genome annotation. The settings will be saved but you can change or update the 
annotations at any later time point in Preferences. 

Podbat tries to connect to Ensembl to fetch the genome data. If you are not 
connected to the Internet or your computer fails to connect to the database at Ensembl, 
you can download some data for some genomes and their annotations from the Podbat 
download tab or generate you own genome files (see below, section Choose organism). 
Once Podbat opens, you should see three panels in the window, the 'genome panel', the 
'control panel' and the 'selected element panel' (Figure 1). 

 
Figure 1. Overview of the Podbat graphical user interface. 
 
The first time you open Podbat, the genome information is missing. You need to set the 
organism you work on in the Preference panel (). 
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Preferences 
If you go to Preferences (Go to: File > Preferences, or for Mac users, Podbat > 
Preferences (⌘,)), you can set some parameters that will be saved between the 
sessions. You can change the working directory (where files are saved to and retrieved 
from), select organism and associated annotation (these are saved with the name 
"organism_annotation.adata", e.g. "schizosaccaromyces_pombe_8_61_1a.adata"). The 
following row contains information of where to find the links for the web connections for 
the gene names. 

The next sections gives the details for the MySQL database if one is to be used for 
storage or retrieval. The default is set to the Podbat server at Karolinska Institutet. You 
can speify the server name, port to be used as well as the name of the database, user and 
the password. To upload data to the central database you will need a username different 
from the default. 

You can set the coloring scheme for the plots in the lower part of the panel. 
Values are saved to the following session. To restore the default values, press the 
default button. 

 
Figure 2. The preference panel. 
 
Here, you also have the option to provide a file for the DNA sequence in the form: 
seq_region_id sequence 
2 GATCACGTACATCACCTTGTAAGAATTTATC... 
8 AATGTGTAATTTGAATCAATTTCTATCCTTTT... 
... 

Choose organism 
Here you also set the organism and the annotation you want to use. If your organism of 
interest is not in the drop-down menu, you can create a new item. From the annotation 
drop-down menu you can use the predefined files or you can add a new genome assembly 
or species. For a certain number of species annotations can be directly downloaded from 
Ensembl. However, as the format for the genome varies, we cannot guarantee a 
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successful download. As an alternative, genomes can be imported from text files. Two 
files required: 
 

1) genome organization file with with the length of of the chromosome (or other 
genetic elements such as plasmids). This file should contain three columns with 
chromosome name, chromosome id (not used) and chromosome length. 
 
2) annotation file with information on the genetic elements (protein coding 
genes,tRNAs, repeat regions...). This file should contain six columns: unique id, 
chromosome name (same as in genome organization file), start (actually left) 
position, end (right) position, strand (+1/-1) and description. 

 
NB When naming the organism, you should use two words separated by "_", e.g. 
Saccharomyces_cerevisiae. 

If the organism has already been loaded, it is possible to only change the 
annotation file. After an annotation has been loaded once, it should be available at the 
drop-down menu at the preference panel. 
 
Example genome organization file: 
1 NC_001133 230208 
2 NC_001134 813178 
3 NC_001135 316617 
4 NC_001136 1531919 
5 NC_001137 576869 
6 NC_001138 270148 
7 NC_001139 1090947 
8 NC_001140 562643 
9 NC_001141 439885 
10 NC_001142 745741 
11 NC_001143 666454 
12 NC_001144 1078175 
13 NC_001145 924429 
14 NC_001146 784334 
15 NC_001147 1091289 
16 NC_001148 948062 
17 NC_001224 85779 
Example annotation file: 
 
YBR285W 2 773918 774352 1 Putative protein of 
unknown function; YBR285W is not an essential gene   
YBR286W 2 774696 776309 1 "Vacuolar 
aminopeptidase Y, processed to mature form by Prb1p APE3 APY1" 
YBR293W 2 787001 788425 1 Permease of basic amino 
acids in the vacuolar membrane VBA2  
YDL001W 4 447982 449274 1 Cytoplasmic protein 
required for sporulation RMD1  
YIR018W 9 384606 385343 1 Basic leucine zipper 
(bZIP) transcription factor YAP5  
YIR035C 9 421023 421787 -1 Putative cytoplasmic 
protein of unknown function 
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Connect to database 
Here you also select the database if you want to connect to one. The default option is the 
central server at Karolinska Institutet, but you can change this to a local database. To 
create a local database, install MySQL if you do not have it already (download) and 
create a database with the name of the organism. 

Creating session 
Once you have selected the organism and annotation, you can load your experimental 
data. There are several options depending on the data format. You can either 1) load files 
from your local network or 2) datasets from the database (local or central). Several 
different formats can be uploaded into Podbat (WIG, BED, GFF, SGR, TXT, TAS). For a 
description of the formats, go to Appendix A. 

Import experimental data from file 
File: Click File > Import > Data from file A new dialog will open where you are 
asked to specify the file format and location. If you have one file for each strand, you can 
upload both in the separate fields, if not, you only need to specify one file. If the data is 
strand specific, mark this selection. You can also chose to specify the platform that you 
used for the experiments. Several formats can be uploaded (see Appendix A). 

Import experimental data from database 
Database: Click File > Import > Data from database 
A new dialog will open with a spreadsheet with all the datasets available at the server for 
the organism you are using. You can see a unique identifier as well as some information 
about each experiment. Select one row and click ‘Import’ to load the data. 

The database settings can be set in the Preference panel. To make use of the 
central database, make sure your firewall settings are set correctly. 

Import annotation data 
Data from other sources can be appended to the data table. Text files can be uploaded 
into Podbat by clicking File > Import > Annotation (TXT). A new window appears 
where you can specify the file you want to use. Check 'Show Options' to improve your 
control of the data (Figure 3). Here you choose which columns will be mapped to each 
other. 
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Figure 3. Loading annotation to map to the data 

Save/Restore session 
You can save the current state of a Podbat session to a named session file. You can use 
that file to restore the Podbat session yourself or share it with colleagues. 

To save a session: Click File > Save or File > Save Session In the Save 
window, select a directory and session file name and click Save. 

To restore a saved session: Click File > Open. In the Open session dialog, 
select a session file and click OK. Podbat ends the current session and restores the saved 
session. 

Visualize 
In the main panel, you can select which region to have in view, indicating chromosome 
number, start and end position (in kb). Press enter to execute the view. The selection 
will be presented in the ‘chromosome view’ and in the ‘genome view’ you will see an 
orange box showing the selection in the genome (Figure 4). The orange box can be 
dragged by the mouse to pan the genome. 
  

 
Figure 4. Setting the coordinates for the genome view. 

Zoom in/out 
You can zoom in to a specific region by clicking and dragging the mouse in the 
‘chromosome view’. To zoom out, enter a larger interval in the main panel. 
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Changing representation 
By clicking on a sample track, you can change the view of the sample panel or delete a 
single sample (Figure 5). You are able to set an individual coloring scheme for each 
sample. To convert the data between linear and logarithmic scale, select option in the 
drop-down menu. You can also change the scale (this can also be done by clicking on the 
sample scale top half to increase the scale, bottom half to decrease it) and the offset on 
the scale here. The easiest way to change the scale is to move the text onto the sample 
representation and turn the mouse wheel (or slide on the track pad). 
  

 
Figure 5. Changing the view for a sample. 

Analyze 
In the ‘Control panel’ (Figure 6 and 7) you can organize data in sets, filter data or 
process the data to determine regions and region averages. 
  

 
Figure 6. Whole view with selection, control panel in to the left. 
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Sets of genes or other elements 
In this 'Sets' view of the Control Panel (Figure 7) you see all the sets that are defined in 
your session. You can load new sets from a text file with the element identifiers (Click 
Edit > Load new list) or you can select it from the table (File > New Set from 
Selection or SHIFT-CTRL-N (SHIFT-⌘-N)). 
 
Example of text file with gene set: 
SPAC15F9.01c 
SPBC713.05 
SPBC6B1.12c 
SPAC1687.08 
I_138872_140253 
I_977150_978343 
II_430620_432154 
III_37173_38830 
 

 
Figure 7. The 'Sets' view of the control panel. 
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Calculate data-defined regions 
In the 'Preprocess' view of the Control Panel you have the choice to determine data-
defined regions (e.g. of protein occupancy or RNA expression). 
By clicking the 'Determine regions' button, a new panel appears where you select the 
threshold (above which the average of the probes in the region has to be), minimal length 
of the region and minimal gap between regions (Figure 3). By checking the 'use HMM' 
box, you chose to determine the regions using Hidden Markov Models. 

Sliding average 
Regions are defined by a sliding average. This average is determined over as many 
probes as specified by the user (in the Length Thres box). When the average is above 
the intensity threshold (Intensity Thres), a region is defined. Regions closer than a 
specified threshold (specified in the Gap box) are merged. 

Hidden Markov Models 
To stratify the data, a Hidden Markov Trace can be determined (Figure 8). For the novice 
to Hidden Markov Models (HMM), here is an excellent primer on HMM. The user may 
use a priori estimated values for the emission and transmission probabilities as well as 
the initial population. In this implementation , there are two states (0 - background, 1 - 
above background). The distance between the states is determined by the user defined 
HMM threshold (HMM Thres) in the preprocess panel. The probabilities can be estimated 
by the Baum-Welsh algorithm. To save computational power, by default the estimation is 
done using 500 probes (from 10,000 to 10499). These numbers can be changed at the 
advanced frame ('first probe' and '# probe' after clicking the 'Adv' button). Podbat 
uses the Java implementation of HMM related algoritms provided in Jahmm. 
 

 
Figure 8. Determine regions within the data. 
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Once regions have been determined, they will be given identifiers as of their position 
(chromosome, start and end). The directionality of the region is given by the order of start 
and end position in case of strand-specific data. Example: II_593002_590222 is 
positioned on chromosome II, resides between bases 590222 and 593002 on the negative 
(Crick) strand.The regions are visualized in the view as empty orange squares. Two sets 
are created, one of the actual regions (in the description you find the genes that are 
overlapping with the region on the same strand or opposite strand (nt)), and one of the 
genes overlapping with the region (Figure 9). 
 

 
Figure 9. Results after determining regions in the data. 

Summarize intensities over regions 
Data within regions (either predefined in annotations or data-defined) can be summarized 
into a single value. Currently, this is done by taking the mean of the values within the 
region. This can be done for the data irrespective of strand (for protein occupancy data, 
'both strands' button), or for only the sense strand (for RNA expression data, 'sense 
strand' button). A third alternative, is to look at the anti-sense or the regions (used to 
look for aberrant or read-through transcription, or just anti-sense transcription, 'anti 
sense' button) (Figure 10). After the calculations, new columns will appear in the 
'Selected elements panel'. 
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Figure 10. Buttons used to calculate the mean intensity value within a region. 

Sort, filter data 
Data in the spreadsheet can be sorted by clicking on the header. A filtering function is 
present in the 'Control panel' (Filter), where you can combine several attributes. You 
can always make a new gene set by going to File > New set from selection. 

Analyze gene sets 

Compare gene sets 
You can compare you different gene sets (Edit > Compare Lists). By selecting two 
sets and clicking the 'compare' button, Podbat will calculate the overlap and the p-value 
given the hypogeometrical distiribution between the two sets. Note that for very small p-
values, the results will show as 0. You can also make new gene sets from the union, 
intersection or the unique elements (Figure 11). 
 

  
Figure 11. Comparison between gene sets. 

Enrichment of gene sets 
To compare gene sets to previously determined sets, e.g. the sets defined by the Gene 
Ontology consortium, you need first to fetch the database (Edit > Compare lists, then 
GeneSets > Fetch GO. For this, you will need the NCBI organism number (e.g. 4896 
for Schizosaccharomyces pombe). Fetching the GO database is a very time consuming 
task so for budding and fission yeast, the data is available at the Podbat download site. 
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Once you have the file on the working directory on your computer, you just need to load 
and activate GO (GeneSets > Activate GO). You can also create a gene set data file 
yourself with the other gene sets (e.g. determined in previous experiments). The tab-
delimited text file has one line for each gene set. For each line, the first field: unique 
identifier, second field: description, third field: number of genes in gene set, subsequent 
fields: the gene identifiers of the genes in the gene set (see example file below). 
 
Example of gene set data file: 
schizosaccharomyces_pombe 
GO:0000001 mitochondrion inheritance 7 SPAC1782.06c
 SPBC28F2.06c SPBC27B12.01c SPAC17H9.17c
 SPAC30C2.06c SPBC1215.02c SPBC12C2.08 
GO:0000009 alpha-1,6-mannosyltransferase activity 3
 SPAC1006.05c SPBC1734.12c SPBC11B10.01 
GO:0000011 vacuole inheritance 3 SPBP8B7.13 SPBC25H2.03
 SPBC354.14c 
GO:0000012 single strand break repair 1 SPCP31B10.05 
GO:0000014 single-stranded DNA specific endodeoxyribonuclease activity
 3 SPBC4F6.15c SPAC13C5.07 SPCC970.01 
GO:0000015 phosphopyruvate hydratase complex 2 SPBPB21E7.01c
 SPBC1815.01 
 

Now you can select a single gene set from your list and click the 'calc 
enrichment' button. Podbat will calculate and, in a new tab with the name of the gene 
set, display the ratio within your selection and the overall ratio for each GO term, as well 
as the number of genes, an enrichment ratio and a p-value (hypogeometric distribution 
(Figure 12). You can sort the data by clicking on the header, or you can copy paste the 
data into another program (such as Excel) for further processing. 

By checking the 'Show settings' box, you can change the default values of the 
background set, which gene identifier to use, as well as thresholds for the number of 
genes that should be in the selection, the enrichment factor and the significance level. 
Click 'Show set' to make a new gene set of the ID selected or written in the text box 
adjacent to the button. 
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Figure 12. Enrichment of GO terms. 
 

Aligning genes by genomic positions 

Gene average plots 
Podbat can also align the data for the selected elements after the start or end position. 
Click Edit > Average gene plot and a new window will open (Figure 13). It is the gene 
set selected in the main control panel that will be aligned. 
 

  
Figure 13. Aligning data of the regions. 
 

You can specify several parameters: the size of the alignment region, if you want 
error bars (CI -confidence interval, then specify the level in box adjacent, SD - standard 
deviation, SDx2 - twice the standard deviation, SEM - standard error of the mean), the 
scale on the Y-axis (min and max), the window and step size to smoothen the curve, 
normalize will set the genome average to 0. You can also choose to stay in the same 
canvas or make a new plot, and which color it will have. By clicking 'draw' the data will 
be processed (Figure 14). Note: For large gene sets and big regions, this process will take 
long time and the program might not be able to finish it. To resolve it, try reducing the 
size (either by breaking the gene set up in smaller sets, or dividing the region in smaller 
regions) or starting up Podbat with more memory. 
 

 
Figure 14. Data alignment. 
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Add statistics 
You can calculate if there is a significant difference between two gene sets. For each bin 
(determined by the window and step size), a t-test will be performed under the null 
hypothesis that there is no difference between the two sets. To compare to sets, you go to 
the menu Edit > Add statistics. Select the two sets you want to compare in the pull 
down menus (both have to be from the latest plot). There are two options for showing the 
regions which are significantly different: 1) by setting the p-value threshold (enter the -
log10 value, i.e. 3 for p<0.001) or 2) by checking the continuous option (Figure 15). 
 

 
Figure 15. Adding statistics to the alignment analysis, fixed threshold at 10-10 

 
By checking the continuous option, the bar will show the p-values on a continuous scale, 
from black (p=1) via red to yellow (p=0) (Figure 16). 
 

 
Figure 16. Adding statistics to the alignment analysis, showing p-values over the entire region 
with the color corresponding to the significance. 

Export plot 
The lastly made figure can be exported as EPS by going to the menu Edit > Export as 
EPS. 

Interact With Database 
You can access the central database and view data. To upload data, get in contact with the 
Podbat development team and you will be sent a password that you can use. 
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Alternatively, you can create a local database. Installing a local MySQL database, and 
change the settings in Podbat Preferences so that Podbat can locate it and communicate 
with the local database. 

Export 
Data in tables can be exported by selecting the cells of interest and the copy (CTRL-C or 
⌘-C) and paste (CTRL-V or ⌘-V) into any text editor or Excel. 

Export to database 
To export to a local database, go to menu File > Export > Data to DatabaseYou 
will need to adjust the default settings in the Preference window and make sure you have 
writer privileges to the database you are trying to connect with. To upload data to the 
central Podbat database at Karolinska Institutet, please contact the Podbat development 
team and you will be issued a password so that you can upload your data. 

Export sets to text file 
The element (gene) sets that has been made in a session and are visualized in the 'Sets' 
tab of the 'Control Panel' can be exported to a text file. Go to menu File > Export > 
Sets to File. The format is the same as is imported in the Gene Set Comparison. The 
first set containing the entire genomic annotation will not be included. To export this you 
can copy and paste it from the 'Selected elements panel. 

Export graphics 
The genome view can be exported to EPS files for publication grade figures. Go to menu 
File > Export > Graphics as EPS 

Export sequence information 
Also the sequences of the selected genetic elements can be retrieved and send to a text 
file in FASTA format. Go to menu File > Export >Element SequencesThis can be 
useful to design PCR primers for verification studies, or to find protein binding motifs 
using e.g. REDUCE. 
 
Example FASTA format: 
>SPCC16C4.22 
TGGAGAAAACATATGGGAAAACTGTATTGCCATTGAGCAGAGTAAAGAGGATAATAAAGCAAGAT 
GAAGACGTACACTACTGTTCTAATGCATCTGCTTTGTTAATTTCAGTAGCTACTGTATGTGTGTTG 
TTGATAAATCAGCTATCTGGGCGACTTAGCACCATTTTGATTGCATAAAAGAAAAAGAAAAATAAA 
AGCTTACCTATTTTATGATTTAGGAATTATTTGTTGAAAAGTTAGCAACAGAGGCTTATCAACTTG 
CCAAATTACAAAAACGTAAAGGAATACGATACAGGGACGTTGAGGACGTTGTACGTAAGGACGAT 
CAATTTGAATTTTTATCAGATTTGTTTTCTATATAA 
 
>SPCC16C4.21 
TGCAGCTCTATCCGGCAAATGTTAAGGGATTGAGATATAGTGAATGTTGCATCTTAACCGCTAAC 
CCATCGGTTCAACATTTTGTCATGCATGATGATGCTGGTGTTCCTCTAACGTACAGCGTTTCCAC 
ACTGCACGCCGAACTTACCGACCACCTATACCTCCCAACCACCAGGAAAACAGTCGCAGTAGGC 
AAGAAAACGCTTTTTGTAGTGCAAAAAAAAAGATTTAAGCCGGAAACATAG 
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Plug-ins 
The functionality of Podbat can be extended by plugins. A selection of plugins are 
available at the plug-ins tab of the Podbat web page. 
Instructions on how to write plugins can be found in Appendix B. 
 
 

Quickstart 
To test the functionality of Podbat, first download the Java package here. 
Follow the instruction available in this pdf-document (Figure 17). 
  

  
Figure 17. Example of Podbat analysis. 
 
 
 
 
 
 
 
 
 

 
Podbat is developed and maintained at Karolinska Institutet, Stockholm, Sweden. 
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Appendix A. File formats 
Before loading data files into Podbat, some preprocessing of the data need to be 
performed, such as aligning the sequences/probes onto the genome and quantifying the 
data at each location of the genome. For more information, we refer to others. There are 
many options for this depending on the platform, e.g. for Affymetrix, TAS can be used. 
There are also R packages to do this. Data files can be uploaded in many different 
formats. If the data files are compressed (zip, gz, ...), you need to decompress them 
before they will be recognized and imported. If you have data in other formats than the 
ones mentioned here, you can convert the data to fit into Podbat. Examples of these 
conversions are FindPeaks - used to generate WIG files from ELAND alignment files 
(Solexa/Illumina), Eland2Wig - used to generate WIG files from ELAND alignment files, 
STAR - used to generate WIG files from BED files. 

Spreadsheet data (TXT) 
To load spreadsheet data, two files are needed, 1) a description file giving the genome 
position information of all data points and 2) a data file with the numerical values for 
each sample and data point. Comments can be added by starting a line with '#' or '!'. Most 
datasets in the ArrayExpress or Geo database are available in this format. 
Example description file: 
ID chr strand start 
3 II -1 1318254 
4 II -1 2614339 
5 I -1 2718766 
6 II -1 4462259 
8 I -1 4461193 
9 III 1 2233423 
10 III 1 1397485 
12 II -1 1005011 
Example data file: 
 sample1 sample2 sample3 sample4 
3 -1.34 -0.05 -0.73 -0.06 
4 0.06 -0.08 -0.15 -0.09 
5 -0.1 -0.14 -0.19 -0.12 
6 -0.15 -0.09 -0.24 -0.41 
8 -0.22 0.15 0.12 0.53 
9 -1.42 -0.05 -0.84 -0.06 
10 2.62 1.91 3.01 2.3 
12 3.58 3.26 2.66 3.37 

 

Affymetrix data (TAS) 
When using Affymetrix GeneChip data, these are ofter processed in (TAS). When using 
TAS, after defining the analysis group (TAG file), calculate signal and p-values (BAR 
file). Choose the option to export the BAR file as text (the BAR file cannot be read by 
Podbat) and the signal.txt file can be uploaded in Podbat. For data with the two strands 
analyzed separately , you will upload two separate files: one for the + strand and another 
for the - strand. For analysis where the data shuld be kept strand specific (transcriptional 
data but usually not protein binding data), check the box for "strand specific". 
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Example TAS file: 
# Number Sequences 1 
# Data signal 
# Scale Log2 
# Genomic Map sp20r_M_v04_new.bpmap 
# AlgName TAS 
# AlgVersion 1.1.02 
# probe_coordinate_convention 0_indexed_center 
 
# Sequence 10 
# Name chr3 
# Number of Hits 17 
 
59987 -0.31479 
60016 -0.38421 
60041 -0.36757 
60061 -0.34329 
60082 -0.30381 
60104 -0.42574 
60125 -0.49113 
60145 -0.54901 
60174 -0.54096 
60195 -0.53333 
60215 -0.51947 
60236 -0.52353 
60257 -0.59274 
60280 -0.67085 
60301 -0.57876 
60327 -0.77498 
60351 -0.86848 

 

WIG 
The wiggle (WIG) file can contain several samples. The file also contains the sample 
name and extras such as colors and the genome position where the browser will open. 
More information on the WIG format. 
Example WIG file: 
browser position chrI:4200-1340700 
#      first track with name "VariableStep" 
#      150 base wide bar graph at arbitrarily spaced positions, 
track type=wiggle_0 name="variableStep" color=50,150,255  
variableStep chrom=chrI span=150 
4701 10.0 
4901 12.5 
5401 15.0 
5601 17.5 
5901 20.0 
6081 17.5 
#      second track with name "fixedStep" 
#      200 base wide points graph at every 300 bases 
#      lines and background are in different colors 
track type=wiggle_0 name="fixedStep" color=0,200,100 
altcolor=255,29,100  
fixedStep chrom=chrI start=7401 step=300 span=200 
10.3 
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4.9 
-0.8 
2.7 
6.6 

 

BED 
The BED file consist of three required columns: chromosome, start and end. Nine 
additional columns are optional, of which three are used by Podbat: name (not 
implemented), score and strand (+/-). More information of the BED format. 
Example BED file: 
track name="bed_format"  
chrI 1000 5000 cloneA -5.6 + 
chrI 2000 6000 cloneB 12.4 - 

 

BedGraph 
More information of the BedGraph format. 
 
Example BedGraph file: 
browser position chrI:5302001-5354701 
# 300 base wide bar graph 
track type=bedGraph name="BedGraph_Format"  color=200,100,0 
altColor=0,100,200 
chrI 5302000 5302300 -1.0 
chrI 5302300 5302600 -0.75 
chrI 5302600 5302900 -0.50 
chrI 5302900 5303200 -0.25 
chrI 5303200 5303500 0.0 
chrI 5303500 5303800 0.25 
chrI 5303800 5304100 0.50 
chrI 5304100 5304400 0.75 
chrI 5304400 5304700 1.00 

 

GFF/GTF 
The GFF file contains 9 columns: seqname, source, feature, start, end, score, strand, 
frame and group. The columns must be separated by tab. Only four of these are used in 
Podbat (start, end, score and strand). Since the GFF and GTF formats only differ at the 
nineth, unused column, GTF data can be uploaded using this option as well. More 
information of the GFF format. Note, for files to be used in Podbat, the "raw" GFF file 
with each sequence cannot be used. The GFF files to be imported need to have a numeric 
score field and non-overlapping sequences. To use Solexa/Illumina data, convert the 
ELAND alignment files to e.g. WIG format (FindPeaks,Eland2Wig). 
 
Example GFF file: 
track name="GFF_example" 
chrI  SEQ1 enhancer  100000  101000  4.5 +  .  TG1 
chrI  SEQ1 promoter  110000  110100  9.3 +  .  TG1 
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chrI  SEQ1 promoter  120000  125000  -6.4 -  .  TG2 

 

SGR 
A simplified version of the GFF file, containing only three columns: chromosome name, 
position and score. 
Example SGR file: 
chr1 5722 1.02 
chr1 6312 0.80 
chr1 6639 1.45 
chr1 6892 4.35 
chr1 6898 9.68 
chr1 7694 0.34 
chr1 7695 0.30 
chr2 10989 0.28 
chr2 10993 0.14 
chr2 11325 0.73 
chr2 11338 0.55 
chr2 11343 0.83 
chr2 12104 1.17 
chr2 12104 0.52 
chr2 14847 0.56 
chr3 24584 0.73 
chr3 24587 0.65 
chr3 24629 0.80 
chr3 24629 0.60 
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Appendix B. Develop Plugins 
Podbat allows programmers to write plugins that access the core data structures and 
windows of Podbat to allow a wide variety of operations. Here we explain how to write a 
plugin and how to get Podbat to load and use your plugin. 

The PodbatPlug interface 
The PodbatPlug interface is very simple. Your Podbat plugin class needs to implement 
this interface to be recognized. It also needs to contain the method run(). 
package plugin.YourPlugIn;  
 
public class YourPlugIn implements PodbatPlug { 
public void run() {} 
} 
For plugin xxx, the name of the package needs to be plugin.xxx and saved in a file named 
plugin.xxx.jar. The class name needs to be xxx. 
To access the Podbat data, you need to import the Podbat.jar file (import Podbat.*;) 

Example: HelloWorld plugin 
package plugin.HelloWorld; 
 
import Podbat.PodbatPlug; 
import javax.swing.*; 
 
public class HelloWorld implements PodbatPlug { 
public void run() { 
JFrame helloFrame= new JFrame(); 
JPanel helloPane = new JPanel(); 
helloPane.add(new JLabel("Hello world")); 
helloFrame.add(helloPane); 
helloFrame.setSize(50, 50); 
helloFrame.setVisible(true); 
} 
} 
 


